П О Р Т А Л                            
С Е Т Е В Ы Х                          
П Р О Е К Т О В                        
  
Поиск по сайту:
                                                 
Главная

О проекте

Web-мастеру
     HTML & JavaScript
     SSI
     Perl
     PHP
     XML & XSLT
     Unix Shell

MySQL

Безопасность

Хостинг

Другое








Самое читаемое:

Учебник PHP - "Для Чайника".
Просмотров 176927 раз(а).

Иллюстрированный самоучитель по созданию сайтов.
Просмотров 74069 раз(а).

Учебник HTML.
Просмотров 73281 раз(а).

Руководство по PHP5.
Просмотров 44160 раз(а).

Хостинг через призму DNS.
Просмотров 50818 раз(а).

Подборка текстов стандартных документов.
Просмотров 44335 раз(а).

Учебник PHP - Самоучитель
Просмотров 50587 раз(а).

Документация на MySQL (учебник & справочное руководство)
Просмотров 50999 раз(а).

Внешние атаки...
Просмотров 41309 раз(а).

Учебник PHP.
Просмотров 36543 раз(а).

SSI в примерах.
Просмотров 27427 раз(а).



 
 
| Добавить в избранное | Сделать стартовой | Помощь




Учебник РНР
Назад Вперёд

Приложение C. Переход от PHP/FI 2 к PHP 3

Содержание
О несовместимости в 3.0
Начальный/конечный тэги
if..endif-синтаксис
while-синтаксис
Типы выражений
Сообщения об ошибках изменены
Сокращённый цикл вычисления boolean
Возвращаемые функциями значения TRUE/FALSE
Иная несовместимость

О несовместимости в 3.0

PHP 3.0 переписан полностью. В нём имеется соответствующий разборщик/parser, который намного надёжнее и быстрее, чем в 2.0. 3.0, а также значительно меньше расходует память. Однако некоторые из этих улучшений невозможны без изменения совместимости, как в синтаксисе, так и в функциональности.

Кроме того, PHP-разработчики попытались прочистить синтаксис и семантику PHP в версии 3.0, и это также вызвало появление некоторой несовместимости. Мы считаем, что в долговременном плане это изменения к лучшему.

В этой главе будет сделана попытка помочь вам преодолеть несовместимости, возникающие при переходе от PHP/FI 2.0 к PHP 3.0. Новые возможности здесь не упоминаются без необходимости.

Программа конвертации, которая может автоматически конвертировать ваши старые PHP/FI 2.0-скрипты, существует. Её можно найти в поддиректории convertor дистрибутива PHP 3.0. Эта программа отлавливает только синтаксические изменения, поэтому вы в любом случае должны внимательно прочитать эту главу.


Назад Оглавление Вперёд
Обработка глобальных переменных Вверх Начальный/конечный тэги


Если Вы не нашли что искали, то рекомендую воспользоваться поиском по сайту:
 





Copyright © 2005-2016 Project.Net.Ru